GHSA-pwv6-872c-gcg6

Cross-Site Request Forgery in Jenkins

At a glance

Published
Updated
CVE
CVE-2017-2613
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L

Description

jenkins before versions 2.44, 2.32.2 is vulnerable to a user creation CSRF using GET by admins. While this user record was only retained until restart in most cases, administrators' web browsers could be manipulated to create a large number of user records (SECURITY-406).

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.32.2
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.34, fixed 2.44

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database