GHSA-pr76-5cm5-w9cj

GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments

At a glance

Published
Updated
CVE
CVE-2023-40267
Aliases
PYSEC-2023-137
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

GitPython before 3.1.32 does not block insecure non-multi options in `clone` and `clone_from`, making it vulnerable to Remote Code Execution (RCE) due to improper user input validation, which makes it possible to inject a maliciously crafted remote URL into the clone command. Exploiting this vulnerability is possible because the library makes external calls to git without sufficient sanitization of input arguments. NOTE: this issue exists because of an incomplete fix for CVE-2022-24439.

Affected packages

PackageVersions
PyPI · gitpythonintroduced 0, fixed 3.1.32

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database