GHSA-pq64-v7f5-gqh8

Pygments vulnerable to Regular Expression Denial of Service (ReDoS)

En bref

Publiée
Mise à jour
CVE
CVE-2021-27291
Alias
PYSEC-2021-141
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

Paquets affectés

PaquetVersions
PyPI · pygmentsintroduced 1.1, fixed 2.7.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database