GHSA-pppg-cpfq-h7wr

JSONPath Plus Remote Code Execution (RCE) Vulnerability

At a glance

Published
Updated
CVE
CVE-2024-21534
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Versions of the package jsonpath-plus before 10.0.7 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of vm in Node. **Note:** There were several attempts to fix it in versions [10.0.0-10.1.0](https://github.com/JSONPath-Plus/JSONPath/compare/v9.0.0...v10.1.0) but it could still be exploited using [different payloads](https://github.com/JSONPath-Plus/JSONPath/issues/226)

Affected packages

PackageVersions
npm · jsonpath-plusintroduced 0, fixed 10.2.0
Maven · org.webjars.npm:jsonpath-plusintroduced 0, last affected 6.0.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database