GHSA-pp7h-53gx-mx7r

Remote Memory Exposure in bl

At a glance

Published
Updated
CVE
CVE-2020-8244
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Description

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Affected packages

PackageVersions
npm · blintroduced 0, fixed 1.2.3
npm · blintroduced 2.0.0, fixed 2.2.1
npm · blintroduced 3.0.0, fixed 3.0.1
npm · blintroduced 4.0.0, fixed 4.0.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database