GHSA-pm9x-4392-2c2p

RubyGems may allow a maliciously crafted gem to overwrite files

En bref

Publiée
Mise à jour
CVE
CVE-2017-0901
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

RubyGems versions 2.6.12 and earlier fail to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

Paquets affectés

PaquetVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.6.13

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database