GHSA-pm78-wxxf-fw98

Cross-site scripting in Apache Tomcat

At a glance

Published
Updated
CVE
CVE-2006-7196

Description

Cross-site scripting (XSS) vulnerability in the calendar application example in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.31, 5.0.0 through 5.0.30, and 5.5.0 through 5.5.15 allows remote attackers to inject arbitrary web script or HTML via the time parameter to cal2.jsp and possibly unspecified other vectors. NOTE: this may be related to CVE-2006-0254.1.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcatintroduced 4.0.0, fixed 4.0.7
Maven · org.apache.tomcat:tomcatintroduced 4.1.0, fixed 4.1.32
Maven · org.apache.tomcat:tomcatintroduced 5.0.0, fixed 5.0.31
Maven · org.apache.tomcat:tomcatintroduced 5.5.0, fixed 5.5.16

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database