GHSA-pj7m-g53m-7638

Bootstrap Cross-site Scripting vulnerability

At a glance

Published
Updated
CVE
CVE-2018-14041
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

In Bootstrap 4.x before 4.1.2, XSS is possible in the data-target property of scrollspy. This is similar to CVE-2018-14042.

Affected packages

PackageVersions
npm · bootstrapintroduced 4.0.0, fixed 4.1.2
Packagist · typo3/cms-coreintroduced 8.0.0, fixed 8.7.23
Packagist · typo3/cms-coreintroduced 9.0.0, fixed 9.5.4
Packagist · typo3/cmsintroduced 8.0.0, fixed 8.7.23
Packagist · typo3/cmsintroduced 9.0.0, fixed 9.5.4
RubyGems · bootstrapintroduced 4.0.0, fixed 4.1.2
Packagist · twbs/bootstrapintroduced 4.0.0, fixed 4.1.2
NuGet · bootstrapintroduced 4.0.0, fixed 4.1.2
NuGet · bootstrap.sassintroduced 4.0.0, fixed 4.1.2
Maven · org.webjars:bootstrapintroduced 4.0.0, fixed 4.1.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database