GHSA-pgq7-jcj5-xx6h

Apache Druid before 0.23.0 vulnerable to clickjacking

At a glance

Published
Updated
CVE
CVE-2022-28889
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Description

In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.

Affected packages

PackageVersions
Maven · org.apache.druid:druidintroduced 0, fixed 0.23.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database