GHSA-pg97-ww7h-5mjr

XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

En bref

Publiée
Mise à jour
CVE
CVE-2019-10785
Alias
SNYK-JS-DOJOX-548257,
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

### Impact _What kind of vulnerability is it? Who is impacted?_ Potential XSS vulnerability for users of `dojox/xmpp` and `dojox/dtl`. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Yes, patches are available for the 1.11 through 1.16 versions. Users should upgrade to one of these versions of Dojo: * 1.16.1 * 1.15.2 * 1.14.5 * 1.13.6 * 1.12.7 * 1.11.9 Users of Dojo 1.10.x and earlier should review this change and determine if it impacts them, and backport the change as appropriate. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ The change applied in https://github.com/dojo/dojox/pull/315 could get added separately as a patch. ### For more information If you have any questions or comments about this advisory: * Open an issue in [dojo/dojox](https://github.com/dojo/dojox/)

Paquets affectés

PaquetVersions
npm · dojoxintroduced 0, fixed 1.11.9
npm · dojoxintroduced 1.12.0, fixed 1.12.7
npm · dojoxintroduced 1.13.0, fixed 1.13.6
npm · dojoxintroduced 1.14.0, fixed 1.14.5
npm · dojoxintroduced 1.15.0, fixed 1.15.2
npm · dojoxintroduced 1.16.0, fixed 1.16.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database