GHSA-pf6m-fxpq-fg8v
Nokogiri implementation of libxslt lacks integer overflow checks
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2017-5029
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Nokogiri prior to 1.7.2, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.
Paquets affectés
| Paquet | Versions |
|---|---|
| RubyGems · nokogiri | introduced 0, fixed 1.7.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2017-5029 ADVISORY
- https://github.com/sparklemotion/nokogiri/issues/1634 WEB
- https://git.gnome.org/browse/libxslt/commit/?id=08ab2774b870de1c7b5a48693df75e8154addae5 WEB
- https://github.com/advisories/GHSA-pf6m-fxpq-fg8v ADVISORY
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2017-5029.yml WEB
- https://github.com/sparklemotion/nokogiri PACKAGE
- https://ubuntu.com/security/CVE-2017-5029 WEB
- https://ubuntu.com/security/notices/USN-3271-1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |