GHSA-p96c-xwx8-3cqj

Payload has a tenant authorization bypass in Multi-Tenant Plugin

En bref

Publiée
Mise à jour
CVE
CVE-2026-105860
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Description

## Impact When using the default tenant array field access, an authenticated user could assign themselves to other tenants. **You are affected if:** - You are using `@payloadcms/plugin-multi-tenant` If you configure the tenants arrayFieldAccess.create/update functions, a secured replacement membership field, you are not affected by this specific default behavior. ## Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ## Workarounds Configure tenants arrayFieldAccess.create and tenants arrayFieldAccess.update so only trusted users authorized for all tenants can modify memberships.

Paquets affectés

PaquetVersions
npm · @payloadcms/plugin-multi-tenantintroduced 0, fixed 3.90.0
npm · @payloadcms/plugin-multi-tenantintroduced 4.0.0-canary.0, fixed 4.0.0-canary.34

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database