GHSA-p746-qw73-qmmx
Magento XML Injection vulnerability in the Widgets Module
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2021-36033
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Module. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
| Packagist · magento/community-edition | introduced 0, fixed 2.3.7-p1 |
| Packagist · magento/community-edition | 2.3.7 |
| Packagist · magento/community-edition | introduced 2.4.2-p1, fixed 2.4.2-p2 |
| Packagist · magento/community-edition | 2.4.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2021-36033 ADVISORY
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb21-64.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |