GHSA-p72w-r6fv-6g5h

druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2024-45384
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Description

Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.

Paquets affectés

PaquetVersions
Maven · org.apache.druid.extensions:druid-pac4jintroduced 0.18.0, fixed 30.0.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database