GHSA-p6mr-xf3r-ghq4
Payload has a CSRF Protection Bypass in Authentication Flow
At a glance
- Published
- Updated
- CVE
- CVE-2026-34749
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Description
### Impact A Cross-Site Request Forgery (CSRF) vulnerability existed in the authentication flow. Under certain conditions, the configured CSRF protection could be bypassed, allowing cross-site requests to be made. Consumers are affected if ALL of these are true: - Payload version **< v3.79.1** - `serverURL` is configured ### Patches This vulnerability has been patched in **v3.79.1**. Additional validation has been added to the authentication flow. Consumers should upgrade to **v3.79.1** or later. ### Workarounds There is no complete workaround without upgrading. If consumers cannot upgrade immediately, setting `cookies.sameSite` to `'Strict'` will prevent the session cookie from being sent cross-site. However, this will also require users to re-authenticate when navigating to the application from external links (e.g. email, other sites).
Affected packages
| Package | Versions |
|---|---|
| npm · payload | introduced 0, fixed 3.79.1 |
References
- https://github.com/payloadcms/payload/security/advisories/GHSA-p6mr-xf3r-ghq4 WEB
- https://nvd.nist.gov/vuln/detail/CVE-2026-34749 ADVISORY
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.79.1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |