GHSA-p692-7mm3-3fxg

actionpack is vulnerable to remote bypass authentication

En bref

Publiée
Mise à jour
CVE
CVE-2015-7576
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication implementation in Action Controller in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not use a constant-time algorithm for verifying credentials, which makes it easier for remote attackers to bypass authentication by measuring timing differences.

Paquets affectés

PaquetVersions
RubyGems · actionpackintroduced 3.1.0, fixed 3.2.22.1
RubyGems · actionpackintroduced 4.0.0, fixed 4.1.14.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database