GHSA-p62g-jhg6-v3rq

Code Injection, Race Condition, and Execution with Unnecessary Privileges in Ansible

En bref

Publiée
Mise à jour
CVE
CVE-2020-10684
Alias
PYSEC-2020-207
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
CVSS_V4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.11, and 2.9.7 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 2.7.0a1, fixed 2.7.17
PyPI · ansibleintroduced 2.8.0a1, fixed 2.8.11
PyPI · ansibleintroduced 2.9.0a1, fixed 2.9.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database