GHSA-mwqv-jff6-5v62

TYPO3 cross-site scripting (XSS) vulnerability in the RemoveXSS function and the backend

At a glance

Published
Updated
CVE
CVE-2010-3715

Description

Multiple cross-site scripting (XSS) vulnerabilities in TYPO3 4.2.x before 4.2.15, 4.3.x before 4.3.7, and 4.4.x before 4.4.4 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the RemoveXSS function, and allow remote authenticated users to inject arbitrary web script or HTML via vectors related to (2) the backend.

Affected packages

PackageVersions
Packagist · typo3/cms-backendintroduced 4.2.0, fixed 4.2.15
Packagist · typo3/cms-backendintroduced 4.3.0, fixed 4.3.7
Packagist · typo3/cms-backendintroduced 4.4.0, fixed 4.4.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database