GHSA-mw5w-cf76-73m8

Magento 2 Community Edition RCE Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2019-7895
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Description

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to layouts can execute arbitrary code through a crafted XML layout update.

Paquets affectés

PaquetVersions
Packagist · magento/community-editionintroduced 2.1, fixed 2.1.18
Packagist · magento/community-editionintroduced 2.2, fixed 2.2.9
Packagist · magento/community-editionintroduced 2.3, fixed 2.3.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database