GHSA-mw3r-pfmg-xp92

Improper Restriction of Recursive Entity References in Apache XMLBeans

En bref

Publiée
Mise à jour
CVE
CVE-2021-23926
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Description

The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks. Affects XMLBeans up to and including v2.6.0.

Paquets affectés

PaquetVersions
Maven · org.apache.xmlbeans:xmlbeansintroduced 0, fixed 3.0.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database