GHSA-mq4v-6vg4-796c

apache-airflow-providers-apache-drill Improper Input Validation vulnerability

At a glance

Published
Updated
CVE
CVE-2023-39553
Aliases
PYSEC-2023-136, PYSEC-2026-1137
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider. Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server. This issue affects Apache Airflow Drill Provider before 2.4.3. It is recommended to upgrade to a version that is not affected.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-apache-drillintroduced 0, fixed 2.4.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database