GHSA-mm9c-4cv4-7rfv
Jenkins allows for Privilege Escalation by Remote Authenticated Users
At a glance
- Published
- Updated
- CVE
- CVE-2015-1806
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Description
The combination filter Groovy script in Jenkins before 1.600 and LTS before 1.596.1 allows remote authenticated users with job configuration permission to gain privileges and execute arbitrary code on the master via unspecified vectors.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.597, fixed 1.600 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.596.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1806 ADVISORY
- https://access.redhat.com/errata/RHSA-2016:0070 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1205620 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-02-27 WEB
- http://rhn.redhat.com/errata/RHSA-2015-1844.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |