GHSA-mm33-5vfq-3mm3

Cross-site Scripting Vulnerability in Action Pack

At a glance

Published
Updated
CVE
CVE-2022-22577
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577. Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1 ## Impact CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks. ## Releases The FIXED releases are available at the normal locations. ## Workarounds Set a CSP for your API responses manually.

Affected packages

PackageVersions
RubyGems · actionpackintroduced 5.2.0, fixed 5.2.7.1
RubyGems · actionpackintroduced 6.0.0, fixed 6.0.4.8
RubyGems · actionpackintroduced 6.1.0, fixed 6.1.5.1
RubyGems · actionpackintroduced 7.0.0, fixed 7.0.2.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database