GHSA-mjpc-qx7h-r8c9

Elasticsearch subject to cross site scripting

At a glance

Published
Updated
CVE
CVE-2018-3824
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

X-Pack Machine Learning versions before 6.2.4 and 5.6.9 had a cross-site scripting (XSS) vulnerability. If an attacker is able to inject data into an index that has a ML job running against it, then when another user views the results of the ML job it could allow the attacker to obtain sensitive information from or perform destructive actions on behalf of that other ML user.

Affected packages

PackageVersions
Maven · org.elasticsearch:elasticsearchintroduced 0, fixed 5.6.9
Maven · org.elasticsearch:elasticsearchintroduced 6.0.0, fixed 6.2.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database