GHSA-mhp6-pxh8-r675

Angular vulnerable to Cross-site Scripting

At a glance

Published
Updated
CVE
CVE-2020-7676
Aliases
SNYK-JS-ANGULAR-570058
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

angular.js prior to 1.8.0 allows cross site scripting. The regex-based input HTML replacement may turn sanitized code into unsanitized one. Wrapping `<option>` elements in `<select>` ones changes parsing behavior, leading to possibly unsanitizing code.

Affected packages

PackageVersions
npm · angularintroduced 0, fixed 1.8.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database