GHSA-mgp5-rv84-w37q
Apache Tomcat has an Improper Input Validation vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2026-24734
- Aliases
- BIT-tomcat-2026-24734
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.tomcat:tomcat-coyote | introduced 11.0.0-M1, fixed 11.0.18 |
| Maven · org.apache.tomcat:tomcat-coyote | introduced 10.1.0-M7, fixed 10.1.52 |
| Maven · org.apache.tomcat:tomcat-coyote | introduced 9.0.83, fixed 9.0.115 |
| Maven · org.apache.tomcat.embed:tomcat-embed-core | introduced 11.0.0-M1, fixed 11.0.18 |
| Maven · org.apache.tomcat.embed:tomcat-embed-core | introduced 10.1.0-M7, fixed 10.1.52 |
| Maven · org.apache.tomcat.embed:tomcat-embed-core | introduced 9.0.83, fixed 9.0.115 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-24734 ADVISORY
- https://github.com/apache/tomcat PACKAGE
- https://lists.apache.org/thread/292dlmx3fz1888v6v16221kpozq56gml WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |