GHSA-mc6j-h948-v2p6

RubyGems Improper Verification of Cryptographic Signature vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2018-1000076
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, and Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contain an Improper Verification of Cryptographic Signature vulnerability in package.rb. This can result in a mis-signed gem being installed, as the tarball would contain multiple gem signatures. This vulnerability has been fixed in 2.7.6.

Paquets affectés

PaquetVersions
RubyGems · rubygems-updateintroduced 2.2.0, fixed 2.7.6
Maven · org.jruby:jruby-stdlibintroduced 0, fixed 9.1.16.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database