GHSA-m956-frf4-m2wr

Ansible is vulnerable to an improper input validation in Ansible's handling of data sent from client systems

En bref

Publiée
Mise à jour
CVE
CVE-2016-9587
Alias
PYSEC-2018-39
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

Ansible before versions 2.1.4.0, 2.2.1.0 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.1.4.0
PyPI · ansibleintroduced 2.2.0.0, fixed 2.2.1.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database