GHSA-m75h-cghq-c8h5

Heap Based Buffer Overflow in libyaml

At a glance

Published
Updated
CVE
CVE-2013-6393

Description

Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags. ## Recommendation - Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.

Affected packages

PackageVersions
npm · libyamlintroduced 0, fixed 0.2.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database