GHSA-m6vm-37g8-gqvh
MySQL Connectors takeover vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-22102
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Description
Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 8.1.0 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in MySQL Connectors, attacks may significantly impact additional products (scope change). Successful attacks of this vulnerability can result in takeover of MySQL Connectors.
Affected packages
| Package | Versions |
|---|---|
| Maven · com.mysql:mysql-connector-j | introduced 0, fixed 8.2.0 |
| Maven · mysql:mysql-connector-java | introduced 0, last affected 8.0.33 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-22102 ADVISORY
- https://github.com/mysql/mysql-connector-j PACKAGE
- https://github.com/mysql/mysql-connector-j/compare/8.1.0...8.2.0 WEB
- https://security.netapp.com/advisory/ntap-20231027-0007 WEB
- https://www.oracle.com/security-alerts/cpuoct2023.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |