GHSA-m6ch-gg5f-wxx3

HTTP Proxy header vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2016-5385
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, as demonstrated by (1) an application that makes a getenv('HTTP_PROXY') call or (2) a CGI configuration of PHP, aka an "httpoxy" issue.

Paquets affectés

PaquetVersions
Packagist · guzzlehttp/guzzleintroduced 6, fixed 6.2.1
Packagist · guzzlehttp/guzzleintroduced 4.0.0-rc2, fixed 4.2.4
Packagist · guzzlehttp/guzzleintroduced 5, fixed 5.3.1
Packagist · drupal/coreintroduced 8.0, fixed 8.1.7
Packagist · bugsnag/bugsnag-laravelintroduced 0, fixed 2.0.2
Packagist · amphp/artaxintroduced 0, fixed 1.0.4
Packagist · amphp/artaxintroduced 2.0.0, fixed 2.0.4
Packagist · padraic/humbug_get_contentsintroduced 0, fixed 1.1.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database