GHSA-m678-f26j-3hrp
Execution with Unnecessary Privileges in JupyterApp
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-39286
- Alias
- PYSEC-2022-42974
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
### Impact _What kind of vulnerability is it? Who is impacted?_ We’d like to disclose an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in the current working directory. This vulnerability allows one user to run code as another. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Users should upgrade to `jupyter_core>=4.11.2`. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ No ### References _Are there any links users can visit to find out more?_ Similar advisory in [IPython](https://github.com/advisories/GHSA-pq7m-3gw7-gq5x)
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · jupyter-core | introduced 0, fixed 4.11.2 |
Références
- https://github.com/jupyter/jupyter_core/security/advisories/GHSA-m678-f26j-3hrp WEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-39286 ADVISORY
- https://github.com/jupyter/jupyter_core/commit/1118c8ce01800cb689d51f655f5ccef19516e283 WEB
- https://github.com/jupyter/jupyter_core PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/jupyter-core/PYSEC-2022-42974.yaml WEB
- https://lists.debian.org/debian-lts-announce/2022/11/msg00022.html WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KKMP5OXXIX2QAUNVNJZ5UEQFKDYYJVBA WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YIDN7JMLK6AOMBQI4QPSW4MBQGWQ5NIN WEB
- https://security.gentoo.org/glsa/202301-04 WEB
- https://www.debian.org/security/2023/dsa-5422 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |