GHSA-m5p9-xvxj-64c8
Flowise and Flowise Chat Embed vulnerable to Stored Cross-site Scripting
At a glance
- Published
- Updated
- CVE
- CVE-2024-9148
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P
Description
Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.
Affected packages
| Package | Versions |
|---|---|
| npm · flowise-embed | introduced 0, fixed 2.0.0 |
| npm · flowise | introduced 0, fixed 2.1.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-9148 ADVISORY
- https://github.com/FlowiseAI/Flowise/commit/8375ebb4ec1ebb2b1295561cc0f63486a29f3fde WEB
- https://github.com/FlowiseAI/FlowiseChatEmbed/commit/6a9645df41371cb69f251038d501ec87b1304c84 WEB
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%402.1.1 WEB
- https://github.com/FlowiseAI/FlowiseChatEmbed PACKAGE
- https://github.com/FlowiseAI/FlowiseChatEmbed/releases/tag/flowise-embed%402.0.0 WEB
- https://www.tenable.com/security/research/tra-2024-40 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |