GHSA-m4wj-hhwj-47qp

Drupal Core Cross-Site Scripting (XSS) Vulnerability

At a glance

Published
Updated
CVE
CVE-2025-31675
Aliases
BIT-drupal-2025-31675, DRUPAL-CORE-2025-004
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 8.0.0, fixed 10.3.14
Packagist · drupal/coreintroduced 10.4.0, fixed 10.4.5
Packagist · drupal/coreintroduced 11.0.0, fixed 11.0.13
Packagist · drupal/coreintroduced 11.1.0, fixed 11.1.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database