GHSA-m434-m5pv-p35w

Insufficient user authorization in Moodle

At a glance

Published
Updated
CVE
CVE-2022-0333
Aliases
BIT-moodle-2022-0333
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

Description

A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.

Affected packages

PackageVersions
Packagist · moodle/moodleintroduced 3.11, fixed 3.11.5
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.8
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.11

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database