GHSA-m434-m5pv-p35w
Insufficient user authorization in Moodle
At a glance
- Published
- Updated
- CVE
- CVE-2022-0333
- Aliases
- BIT-moodle-2022-0333
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.
Affected packages
| Package | Versions |
|---|---|
| Packagist · moodle/moodle | introduced 3.11, fixed 3.11.5 |
| Packagist · moodle/moodle | introduced 3.10, fixed 3.10.8 |
| Packagist · moodle/moodle | introduced 3.9, fixed 3.9.11 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0333 ADVISORY
- https://github.com/moodle/moodle/commit/2ee27313cea0d7073f5a6a35eccdfddcb3a9adad WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=2043663 WEB
- https://github.com/moodle/moodle PACKAGE
- https://moodle.org/mod/forum/discuss.php?d=431100 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |