GHSA-m429-fhmv-c6q2
Improper Verification of Cryptographic Signature in ansible
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2020-14365
- Alias
- PYSEC-2020-209
- CVSS_V3
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
Description
A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when `disable_gpg_check` is set to `False`, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 2.8.0a1, fixed 2.8.15 |
| PyPI · ansible | introduced 2.9.0a1, fixed 2.9.13 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2020-14365 ADVISORY
- https://github.com/ansible/ansible/commit/1d043e082b3b1f3ad35c803137f5d3bcbae92275 WEB
- https://github.com/ansible/ansible/commit/1fa2d5fd6b768120b76a77929e27302b06accc0c WEB
- https://github.com/ansible/ansible/commit/9bea33ffa3be3d64827f59882d95b817cfab9b7e WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1869154 WEB
- https://github.com/advisories/GHSA-m429-fhmv-c6q2 ADVISORY
- https://github.com/ansible/ansible PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-209.yaml WEB
- https://www.debian.org/security/2021/dsa-4950 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |