GHSA-m3x6-9v6h-4g28

Cross-site Scripting in Apache Struts

En bref

Publiée
Mise à jour
CVE
CVE-2016-4003
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when using a single byte page encoding, allows remote attackers to inject arbitrary web script or HTML via multi-byte characters in a url-encoded parameter.

Paquets affectés

PaquetVersions
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, fixed 2.3.28

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database