GHSA-jxjc-6xmh-h7mg

Magento 2 Community Edition XSS Vulnerability

At a glance

Published
Updated
CVE
CVE-2020-24408
Aliases
BIT-magento-2020-24408
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by a persistent XSS vulnerability that allows users to upload malicious JavaScript via the file upload component. This vulnerability could be abused by an unauthenticated attacker to execute XSS attacks against other Magento users. This vulnerability requires a victim to browse to the uploaded file.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 0, fixed 2.4.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database