GHSA-jwxh-wj79-ccm6

Magento Reflected Cross-site Scripting vulnerability via 'file' parameter

At a glance

Published
Updated
CVE
CVE-2021-21029
Aliases
BIT-magento-2021-21029
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 0, fixed 2.3.6-p1
Packagist · magento/community-editionintroduced 2.4.0, fixed 2.4.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database