GHSA-jw9f-hh49-cvp9

Nokogiri contains libxml Out-of-bounds Write vulnerability

At a glance

Published
Updated
CVE
CVE-2021-3517
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Description

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application. Nokogiri prior to version 1.11.4 used a vulnerable version of libxml2. Nokogiri 1.11.4 updated libxml2 to version 2.9.11 to address this and other vulnerabilities in libxml2.

Affected packages

PackageVersions
RubyGems · nokogiriintroduced 0, fixed 1.11.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database