GHSA-jmf4-pq78-f8vj
Moderate severity vulnerability that affects org.apache.hive:hive-jdbc
At a glance
- Published
- Updated
- CVE
- CVE-2018-1314
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Description
In Apache Hive 2.3.3, 3.1.0 and earlier, Hive "EXPLAIN" operation does not check for necessary authorization of involved entities in a query. An unauthorized user can do "EXPLAIN" on arbitrary table or view and expose table metadata and statistics.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.hive:hive-jdbc | introduced 0, fixed 2.3.4 |
| Maven · org.apache.hive:hive-jdbc | introduced 3.0.0, fixed 3.1.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1314 ADVISORY
- https://github.com/advisories/GHSA-jmf4-pq78-f8vj ADVISORY
- https://lists.apache.org/thread.html/3da47dbcbf09697387f29d2f1aed970523b6b334d93afd3cced23727@%3Cdev.hive.apache.org%3E WEB
- http://www.securityfocus.com/bid/105884 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |