GHSA-jm9x-rx9x-wpqj
OAuth2 client ID and secret exposed through the web browser
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-9014
- Alias
- PYSEC-2026-1775
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Description
pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 8.12 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-9014 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/7945 WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://www.pgadmin.org/docs/pgadmin4/8.12/release_notes_8_12.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |