GHSA-jgcr-9c2q-rvp8

Apache Struts is vulnerable to Cross-site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2008-6682

Description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.0.x before 2.0.11.1 and 2.1.x before 2.1.1 allow remote attackers to inject arbitrary web script or HTML via vectors associated with improper handling of (1) " (double quote) characters in the href attribute of an s:a tag and (2) parameters in the action attribute of an s:url tag.

Paquets affectés

PaquetVersions
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, fixed 2.0.11.1
Maven · org.apache.struts:struts2-coreintroduced 2.1.0, fixed 2.1.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database