GHSA-jff2-qjw8-5476

Command Injection Vulnerability in systeminformation

At a glance

Published
Updated
CVE
CVE-2021-21388
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:H

Description

### Impact command injection vulnerability ### Patches Problem was fixed with a parameter check. Please upgrade to version >= 5.6.4 ### Workarounds If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() ... do only allow strings, reject any arrays. String sanitation works as expected.

Affected packages

PackageVersions
npm · systeminformationintroduced 0, fixed 5.6.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database