GHSA-j857-2pwm-jjmm

Apache Airflow vulnerable to Insertion of Sensitive Information Into Sent Data

En bref

Publiée
Mise à jour
CVE
CVE-2024-50378
Alias
BIT-airflow-2024-50378, PYSEC-2026-1134
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Description

Airflow versions before 2.10.3 have a vulnerability that allows authenticated users with audit log access to see sensitive values in audit logs which they should not see. When sensitive variables were set via airflow CLI, values of those variables appeared in the audit log and were stored unencrypted in the Airflow database. While this risk is limited to users with audit log access, it is recommended to upgrade to Airflow 2.10.3 or a later version, which addresses this issue. Users who previously used the CLI to set secret variables should manually delete entries with those variables from the log table.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.10.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database