GHSA-j788-fx57-99wp

Cross-site scripting in Apache Tomcat

At a glance

Published
Updated
CVE
CVE-2009-0781

Description

Cross-site scripting (XSS) vulnerability in jsp/cal/cal2.jsp in the calendar application in the examples web application in Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 allows remote attackers to inject arbitrary web script or HTML via the time parameter, related to "invalid HTML."

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcatintroduced 4.1.0, last affected 4.1.39
Maven · org.apache.tomcat:tomcatintroduced 5.5.0, last affected 5.5.27
Maven · org.apache.tomcat:tomcatintroduced 6.0.0, fixed 6.0.20

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database