GHSA-j77q-2qqg-6989

Apache Struts vulnerable to remote arbitrary command execution due to improper input validation

En bref

Publiée
Mise à jour
CVE
CVE-2017-5638
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:H

Description

Apache Struts versions prior to 2.3.32 and 2.5.10.1 contain incorrect exception handling and error-message generation during file-upload attempts using the Jakarta Multipart parser, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

Paquets affectés

PaquetVersions
Maven · org.apache.struts:struts2-coreintroduced 2.3.0, fixed 2.3.32
Maven · org.apache.struts:struts2-coreintroduced 2.5.0, fixed 2.5.10.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database