GHSA-j6f7-g425-4gmx
Pillow is vulnerable to Denial of Service (DOS) in the Jpeg2KImagePlugin
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2014-3598
- Alias
- PYSEC-2015-15
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a denial of service via a crafted image.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pillow | introduced 0, fixed 2.5.3 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2014-3598 ADVISORY
- https://github.com/python-pillow/Pillow/commit/347a1d8d956f9e64af4463ee25311b60cdd5657d WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2015-15.yaml WEB
- https://github.com/python-pillow/Pillow PACKAGE
- https://pypi.python.org/pypi/Pillow/2.5.3 WEB
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00056.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |