GHSA-j4rj-fgcq-wmqp

Cockpit - Content Platform vulnerable to XSS through name or email argument names

En bref

Publiée
Mise à jour
CVE
CVE-2025-7053
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Description

A vulnerability was found in Cockpit versions up to 2.11.3. This issue affects some unknown processing instances of the file /system/users/save. The manipulation of the arguments "name" or "email" leads to cross-site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 will address this issue. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted accordingly. A patch and new release were made available very quickly.

Paquets affectés

PaquetVersions
Packagist · cockpit-hq/cockpitintroduced 0, fixed 2.11.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database